{"id":312,"date":"2015-10-26T15:17:05","date_gmt":"2015-10-26T15:17:05","guid":{"rendered":"http:\/\/www.eminozlem.com\/?p=312"},"modified":"2015-10-26T15:17:05","modified_gmt":"2015-10-26T15:17:05","slug":"apache-not-working-after-reboot-varnish-unable-to-start","status":"publish","type":"post","link":"https:\/\/eminozlem.com\/tr\/apache-not-working-after-reboot-varnish-unable-to-start\/","title":{"rendered":"Apache not working after reboot, varnish unable to start"},"content":{"rendered":"<p>So I rebooted my server and everything seemed to be working, mysql, apache everything running but the websites werent loading. I could not instantly remember the cause because a machine reboot is not something you do on your server every day.<\/p>\n<p>The reason was I had varnish installed and it failed to start after reboot because of &#8220;compilers access tweak&#8221; . I already had varnish added to allowed users but still it did not start.<\/p>\n<p>So, if you have varnish install and after a reboot if your websites fail loading even if apache is running; check varnish status and if you are getting errors such as:<\/p>\n<ul>\n<li>VCL compilation failed<\/li>\n<li>Permission denied<\/li>\n<li>compiler failed, exited with code 1<\/li>\n<\/ul>\n<p>the compilers may be the culprit.<\/p>\n","protected":false},"excerpt":{"rendered":"<p>So I rebooted my server and everything seemed to be working, mysql, apache everything running but the websites werent loading. I could not instantly remember the cause because a machine reboot is not something you do on your server every day. The reason was I had varnish installed and it failed to start after reboot&#8230;<\/p>\n","protected":false},"author":1,"featured_media":313,"comment_status":"open","ping_status":"closed","sticky":false,"template":"","format":"standard","meta":{"_acf_changed":false,"_kad_post_transparent":"","_kad_post_title":"","_kad_post_layout":"","_kad_post_sidebar_id":"","_kad_post_content_style":"","_kad_post_vertical_padding":"","_kad_post_feature":"","_kad_post_feature_position":"","_kad_post_header":false,"_kad_post_footer":false,"_kad_post_classname":"","footnotes":""},"categories":[1],"tags":[],"class_list":["post-312","post","type-post","status-publish","format-standard","has-post-thumbnail","hentry","category-web"],"acf":[],"_links":{"self":[{"href":"https:\/\/eminozlem.com\/tr\/wp-json\/wp\/v2\/posts\/312","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/eminozlem.com\/tr\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/eminozlem.com\/tr\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/eminozlem.com\/tr\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/eminozlem.com\/tr\/wp-json\/wp\/v2\/comments?post=312"}],"version-history":[{"count":0,"href":"https:\/\/eminozlem.com\/tr\/wp-json\/wp\/v2\/posts\/312\/revisions"}],"wp:featuredmedia":[{"embeddable":true,"href":"https:\/\/eminozlem.com\/tr\/wp-json\/wp\/v2\/media\/313"}],"wp:attachment":[{"href":"https:\/\/eminozlem.com\/tr\/wp-json\/wp\/v2\/media?parent=312"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/eminozlem.com\/tr\/wp-json\/wp\/v2\/categories?post=312"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/eminozlem.com\/tr\/wp-json\/wp\/v2\/tags?post=312"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}